1. Visvid

    Visvid London Newbie

    Joined:
    Sep 7, 2012
    Messages:
    29
    Location:
    London UK
    Have purchased a Bluetooth LED from a recent visit to Singapore and initial tests are very promising.. Last Night (Sunday) set everything up and downloaded the App to my phone. You need to use your existing DJI account details for the initial log on and after the app will display the word scanning until it has connected, it is all very straightforward.

    The best thing about this though is the ability to tweak the gains and settings etc while the model is flying which saves time and shows the effects of the tweaks immediately. I can see that this will become an invaluable tool for enthusiasts. One small point though is that the App showed an available update which I downloaded this which then gave me a firmware version mismatch between the Blue tooth LED and the WKM so an upgrade to the WKM is now necessary. Initial tuning of a new set up would benefit greatly from this as it saves so much time, my model flies like a dream thanks to Geoff at Quadcopters.co.uk but always looking to push the limits that little bit further I adjusted some settings and have refined the stability even further.

    In Singapore the unit cost in the region of £66 - £68 while in the UK it is advertised in the region of £79 and while it really is a time saver once again DJI have extremely high price points on there products. Just a pity that there support is non existent considering their prices..
     
  2. Visvid

    Visvid London Newbie

    Joined:
    Sep 7, 2012
    Messages:
    29
    Location:
    London UK
    I spoke to soon.....

    After upgrading the firmware as required by the app software message and following every letter of the instructions, now at least half a dozen times, the upgrade is stopping the unit from working, despite uninstalling the app and reinstalling I am still getting the firmware version mismatch message in 'chinglish' have spent all morning researching this issue to find that many others are having the same issues, all I am getting is a flashing red led and no connection on Blue tooth, everything is updated but no joy.. any ideas anyone... please... I have sent a problem report to DJI but in reality don't expect a reply.. I think that my days of DJI are coming to an end .. am fed up of spending so much money and just getting more an more issues :-(
     
    Last edited by a moderator: Jul 22, 2013
  3. MombasaFlash

    MombasaFlash Heli's & Tele's bloke

    Joined:
    Jul 19, 2011
    Messages:
    1,294
    Location:
    France
    Don't like to say "... told you so", but ... Told you so!

    I raised this exact concern HERE when the WKM Assistant was first announced in March. How would DJI handle the compatibility between different firmware versions and the WKM Assistant iOS app?

    We now see that with the very first update that apparently they haven't. Because now loads of people who are accustomed to maintaining up-to-date iPhone apps will fall into this trap and suddenly their Bluetooth LED connection will become useless, unless they upgrade to the new, untested, untrusted 5.24 firmware.

    DJI Fkcued up again. They must host the only one in two billion apps that is guaranteed to screw up its users. They are now going to have to retrace and offer versions of WKM Assistant somehow.

    Ho-Hum.
     
  4. saidquad

    saidquad New Member

    Joined:
    Dec 26, 2011
    Messages:
    113
    I guess a2m is really the best suited brand name for DJI autopilot systems after all!
     
  5. MombasaFlash

    MombasaFlash Heli's & Tele's bloke

    Joined:
    Jul 19, 2011
    Messages:
    1,294
    Location:
    France
    Help is at hand.
    I have uploaded a zipped folder containing WM Assistant 1.3 & 1.4.

    v1.4 is for the new FW5.24 and v1.3 is for the previous FW5.22

    I don't know how Windoze handles it but to downgrade the iOS app on a Mac:

    1. Delete the v1.4 app from the iPhone or iPad
    2. Delete the same from iTunes
    3. Drag the older app onto the iTunes Apps window
    4. Select the tick box to make it active
    5. sync your iPhone/iPad

    The zip file is HERE
     
  6. Visvid

    Visvid London Newbie

    Joined:
    Sep 7, 2012
    Messages:
    29
    Location:
    London UK
    Hi MombassaFlash... Thank you so much for your help and also the time you have taken to help with this mess... guess what it now works !!! pity DJI were not as quick in releasing something that worked, seriously though thanks again for your help really appreciated :)
     
  7. Visvid

    Visvid London Newbie

    Joined:
    Sep 7, 2012
    Messages:
    29
    Location:
    London UK
    Reply from DJI USA

    Thought I would post the following response I received from DJI regarding the lack of support... interesting that they recognise the shortfalls

    'DJI Innovations
    Paul,
    I understand your frustration--along with the frustration of many others. We are working on developing a strong support system for our customers, but it is something that takes time.
    Our current support is in our network of dealers. Currently the most efficient way to receive support is to speak to your dealer. Additionally, you can email europe.support@dji-innovations.com and get assistance that way, but know that they will contact your dealer to resolve the issue.
    I know that this is not ideal, which is why we are working on a better system. Thanks for being patient with us this far. As sometimes it may not seem like it, we do value and appreciate each one of our users and want to provide them with a better experience.



     
  8. buddyrama

    buddyrama New Member

    Joined:
    Jan 10, 2012
    Messages:
    16
    I'm getting to this late, but when I try to sync 1.3 in iTunes with my phone it tells me I'm not authorized , even though I've authorized my computer. I'm not sure what the problem is.

    thanks.

    m

     
  9. Tahoe Ed

    Tahoe Ed Active Member

    Joined:
    Sep 14, 2011
    Messages:
    1,954
    Press the control key when you click on the app.
     
  10. buddyrama

    buddyrama New Member

    Joined:
    Jan 10, 2012
    Messages:
    16
    Ed, my phone is on iOS 7.1 and my iTunes is 11.1 when i hold the control key down and click the downloaded app 1.3, it gives me the option to open. However, after i replace the app I still get the not authorized dialogue box. stumped
     

Share This Page